登陆

电脑网络:交换机VLAN基础知识及根本区分办法,揭开VLAN的面纱

admin 2019-10-27 229人围观 ,发现0个评论

一.VLAN根底

VLAN(Virtual Loca电脑网络:交换机VLAN基础知识及根本区分办法,揭开VLAN的面纱l Area Network,虚拟局域网)是一种将局域网设备从逻辑上区分红一个 个网段,然后完成虚拟工作组的数据交流技能,这种技能经过在局域网数据帧上界说扩展字段, 来对物理网络进行逻辑上的切割,然后限制局域网数据帧的转发规模,缩小播送域。VLAN技 术首要运用于交流机、路由器和无线操控器等网络设备中。

VLAN根底及简略的VLAN区分办法

同一个VLAN中的用户间通讯就和在一个局域网内相同,同一个VLAN中的播送只要VLAN中的 成员才干听到,而不会传输到其他的VLAN中去,然后操控不必要的播送风暴的发生。一起, 若没有路由,不同VLAN之间不能彼此通讯,然后提高了不同工作组之间的信息安全性。网络 办理员能够经过装备VLAN之间的路由来全面办理网络内部不同工作组之间的信息互访。

VLAN根底及简略的VLAN区分办法

1技能特色

(1)端口的分隔。即便在同一个交流机上,处于不同VLAN的端口也是不能通讯的。这样一个物理的交流机能够当作多个逻辑的交流机运用。

(2)网络的安全。不同VLAN不能直接通讯,杜绝了播送信息的不安全性。

(3)灵敏的办理。更改用户所属的网络不必换端口和连线,只更改软件装备就能够了。

2.TAG和UNTAG

依据端口的VLAN,这是最常运用的一种VLAN区分办法,运用也最为广泛、最有用,现在绝大多数VLAN协议的交流机都供给这种VLAN装备办法。这种区分VLAN的办法是依据以太网交流机的交流端口来区分的,它是将VLAN交流机上的物理端口和VLAN交流机内部的PVC(永久虚电路)端口分红若干个组,每个组构成一个虚拟网,相当于一个独立的VLAN交流机。

IEEE于1999年发布了用以规范VLAN完成的IEEE Std 802.1Q规范。 IEEE 802.1Q协议规范为各种局域网网络结构界说了VLAN的Tag字段,不同网络结构中,衔接 设备能够经过一起的数据特征进行VLAN辨认。

关于常见的以太网网络模型,其首要的报文封装格局类型有两种,别离为Ethernet II型和 802.2/802.3型。关于这两种以太网报文的封装格局,IEEE 802.1Q协议规范在数据帧首部的目 的MAC地址(DA)和源MAC地址(SA)后界说了VLAN Tag,用以标识VLAN的相关信息。

VLAN根底及简略的VLAN区分办法

VLAN根底及简略的VLAN区分办法

3. 端口的链路类型

关于不同部分需求互访时,可经过路由器转发,并合作依据MAC地址的端口过滤。对某站点的拜访途径上最靠近该站点的交流机、路由交流机或路由器的相应端口上,设定可经过的MAC地址集。这样就能够避免不合法侵略者从内部盗用IP地址从其他可接入点侵略的或许。

以太网端口有 3种链路类型:access、trunk、General

Access类型端口只能归于1个VLAN 般用于衔接计算机端口;

Trunk类型端口能够答应多个VLAN经过,能够接纳和发送多个VLAN 报文,一般用于交流机之间的衔接;

General类型端口能够答应多个VLAN经过,能够接纳和发送多个VLAN 报文,能够用于交流机的间衔接也能够用于衔接用户计算机。

General端口和Trunk端口在接纳数据时处理思路办法是相同的,仅有区其他处在于发送数据时:General端口能够答应多个VLAN报文发送时不打标签,而Trunk端口只答应缺省VLAN报文发送时不打标签。

缺省VLAN( PVID):

Access端口只归于1个VLAN 所以它缺省VLAN便是它地点VLAN不必设置;

General端口和 Trunk端口归于多个VLAN,所以需求设置缺省VLAN 电脑网络:交换机VLAN基础知识及根本区分办法,揭开VLAN的面纱ID。缺省情况下 Hybrid端口和Trunk端口缺省VLAN为VLAN 1;

假如设置了端口缺省VLAN ID当端口接纳到不带VLAN Tag报文后则将报文转发到归于缺省VLAN的端口;当端口发送带有VLAN Tag报文时,假如该报文 VLAN ID和端口缺省VLAN ID相同,则体系将去掉报文VLAN Tag,然后再发送该报文。

交流机接口收支数据处理进程:

Acess端口收报文:收到个报文判别是否有VLAN信息:假如没有则打上端口 PVID并进行交流、转发,假如有则直接丢掉(缺省) Acess端口发报文:将报文VLAN信息剥离直接发送出去

trunk端口收报文:收到一个报文,判别是否有VLAN信息:假如没有则打上端口 PVID 并进行交流转发,假如有判别VLAND ID是否在该trunk的答应规模内,假如在规模内则转发,不然丢掉

trunk端口发报文:比较端口PVID和即将发电脑网络:交换机VLAN基础知识及根本区分办法,揭开VLAN的面纱送报文VLAN信息假如两者持平则剥离VLAN信息再发送,假如不持平则直接发送

General端口收报文:收到一个报文,判别是否有VLAN信息:假如没有则打上端口 PVID 并进行交流转发。假如有则判别该General端口是否答应该VLAN数据进入:假如能够则转发,不然丢掉(此刻端口上untag装备是不必考虑,untag装备只对发送报文时起作用)

General端口发报文:

1、判别该VLAN在本端口特点

2、假如是untag,则剥离VLAN信息再发送;假如是tag,则直接发送.

VLAN根底及简略的VLAN区分办法

二.怎么区分VLAN

1. 如下图所示,接入交流机是二层交流机,运用会聚交流机(三层交流机)作为用户的网关。

2. PC1和PC2别离归于VLAN 2和VLAN 3,经过接入交流机SW2接入会聚交流机。

3. PC3和PC4归于VLAN 4,经过SW3接入会聚交流机。

4. 会聚交流机作为PC1、PC2、PC3和PC4的网关,完成用户PC间电脑网络:交换机VLAN基础知识及根本区分办法,揭开VLAN的面纱的互访以及Internet拜访。

5. 内网VLAN 2的网段为192.168.2.0/24,VLAN 3的网段为192.168.3.0/24,VLAN 4的网段为192.168.4.0/24。

装备思路

1. 装备接入交流机,依据接口区分VLAN,完成二层互通。

2. 装备会聚交流机作为用户的网关并启用DHCP功用,完成三层互通并为用户主动分配IP。

3. 装备会聚交流机与AR相连的接口及默许路由,完成与AR的对接。

4. 装备AR与会聚交流机相连的接口及到内网网段的路由,完成与会聚交流机的对接。

5. 装备AR的上网功用。

6. 装备NAT完成内网拜访互联网

操作过程

一、装备接入交流机

将接口参加相应VLAN

system-view

[SW2] vlan batch 2 3

[SW2] interface gigabitethernet 0/0/1

[SW2-GigabitEthernet0/0/1] port link-type access

[SW2-GigabitEthernet0/0/1] port default vlan 2

[SW2-GigabitEthernet0/0/1] quit

[SW2] interface gigabitethernet 0/0/3

[SW2-GigabitEthernet0/0/3] port link-type access

[SW2-GigabitEthernet0/0/3] port default vlan 3

[SW2-GigabitEthernet0/0/3] quit

[SW2] interface gigabitethernet 0/0/2

[SW2-GigabitEthernet0/0/2] port link-type trunk

[SW2-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3

SW3也相似,这儿就不贴脚本啦

装备会聚交流机

1. 将互联接口参加相应VLAN

system-view

[SW1] vlan batch 2 3 4

[SW1] interface gigabitethernet 0/0/2

[丹阳SW1-GigabitEthernet0/0/2] port link-type trunk

[SW1-GigabitEthernet0/0/2] port trunk allow-pass vlan 2 3

[SW1-GigabitEthernet0/0/2] quit

[SW1] interface gigabitethernet 0/0/3

[SW1-GigabitEthernet0/0/3] port link-type access

[SW1-GigabitEthernet0/0/3] port default vlan 4

[SW1-GigabitEthernet0电脑网络:交换机VLAN基础知识及根本区分办法,揭开VLAN的面纱/0/3] quit

2、装备VLANIF接口和DHCP服务器

[SW1] dhcp enable

[SW1] interface vlanif 2

[SW1-Vlanif2] ip address 192.168.2.1 255.255.255.0

[SW1-Vlanif2] dhcp select interface

[SW1-Vlanif2] dhcp server dns-list 114.114.114.114

[SW1-Vlanif2] quit[SW1] interface vlanif 3

[SW1-Vlanif3] ip address 192.168.3.1 255.255.255.0

[SW1-Vlanif3] dhcp select inter电脑网络:交换机VLAN基础知识及根本区分办法,揭开VLAN的面纱face

[SW1-Vlanif3] dhcp server dns-list 114.114.114.114

[SW1-Vlanif3] quit[SW1] interface vlanif 4

[SW1-Vlanif4] ip address 192.168.4.1 255.255.255.0

[SW1-Vlanif4] dhcp select interface

[SW1-Vlanif4] dhcp server dns-list 114.114.114.114[SW1-Vlanif4] quit

请关注微信公众号
微信二维码
不容错过
Powered By Z-BlogPHP